Main Menu
Savage XR
XR Development
Active Servers
You must enable javascript to see
this content!
Map of the Moment
XR Official Website
SavageXR.com
Teamspeak 3
You must enable javascript to see this content!
Bug Tracker
Viewing Bug #262: GLSL Shaders not showing when connected to certain SFE* servers!
Category Savage Client Posted By Mohican Last Updated Mar 29, 2009
Assigned to Mohican Status Fixed Priority Ultra High
Affected Products XR Windows
Description This is serious stuff!
I noticed while playing today that there were no GLSL shaders showing.
When I connected to the XR Test Server the shaders showed up, and dissappeared again when I connected to EvO's EU server.
I am sure that this did not used to be the case, and shaders used to show whatever the server I connected to.

I have an 8800 GTX running the very latest nvidia drivers.



Pages: [1] [2]
Comments
Mohican
Order of the Stick
Former XR Dev

on 2009-01-29 23:34:16

The mystery is getting worse:
I launched XR, then connected to EvO's EU Public -> No Shaders
I then connected to Leet US Public -> Shaders showing
I then connected back to EvO's -> No Shaders.

So it seems that some server setting is switching off shaders on the client...
Mohican
Order of the Stick
Former XR Dev

on 2009-01-29 23:36:54

Automated Messages:
The assignee of this bug has been changed to Senthryl.

Admin Comment:
Do you mind taking a look?
Mohican
Order of the Stick
Former XR Dev

on 2009-01-29 23:41:03

This could help: I have noticed in the console that about 20 warning messages about CVAR_TRANSMITS from the server when connecting to EvO's EU Public.
This does not happen on Leet US Public.
Mohican
Order of the Stick
Former XR Dev

on 2009-01-29 23:42:38

The same problem of CVAR_TRANSMITS and Shaders missing happens on the following servers:
- Groentjuh's & Girls
- Community EU Public
Mohican
Order of the Stick
Former XR Dev

on 2009-01-29 23:45:27

Actually, forget about the CVAR_TRANSMITS, the Leet server shows these messages as well. It must be something else...
Django
Administrator

on 2009-01-30 13:40:53

Groentjuh
Newerth Serveradmin, German Mirror and Webdeveloper
Administrator

on 2009-01-30 21:42:25

The difference between those servers seems to be: They play a different map
Django
Administrator

on 2009-01-30 23:13:54

The issue occurs when you first load XR on to a map with the cvar gfx_fog set to 0

An example map is: http://www.newerth.com/?id=maps&mid=1053 (mini_doom)

A simple fix for this issue would be to detect maps with it gfx_fog 0 and force it to gfx_fog 1 or take all maps with gfx_fog 0 offline from the map database.
H3027
Newerth PR Manager

on 2009-02-05 08:59:52

Just force fog clientside. With a distance that looks almost the same as without fog: like 20000.
Senthryl
Code Poet
Full Member

on 2009-02-09 21:53:33

Automated Messages:
The assignee of this bug has been changed from Senthryl to Jag.

Admin Comment:
I'm far too busy at the moment to take a look at this, and the "Assignee" feature is broken so I have to assign it to someone else (can't set to "Not Assigned").
Pages: [1] [2]
 
Post Comment
You need to login to post a comment
Personal Menu
Welcome, Guest. Please login below or register
 
 
118 Guests
1 User
Daemon
Please welcome bhiomapion, our newest member.
Become a Fan
Give us +1
Random Poll
What do you like most in any newly made maps?
Instant action!
Great looking scenery.
Balanced gameplay, long matches.
Niche gameplay, scripts!
Latest Image
Latest Image
Click to view
Shout Out Loud
Posted by FORTOCHKA(ua)
If you suffering from warp gold, than try o reconnect the servar until it gone. Just donate you lag before.
Posted by mutan
Posted by Precim
I like tomatoes with ketchup. :)))
Posted by Necrophiliac
If you suffering from warp lag, than try o reconnect the servar until it gone. Just donate you gold before.
Posted by d00mer
it seems like the harvest time has passed, so now THE farmers have to improve their skills ))
Log in to shout!