Main Menu
Savage XR
XR Development
Active Servers
You must enable javascript to see
this content!
Map of the Moment
XR Official Website
SavageXR.com
Teamspeak 3
You must enable javascript to see this content!
Bug Tracker
Viewing Bug #261: Textures not displayed on old graphics cards!
Category Savage Client Posted By Django Last Updated Jan 24, 2010
Assigned to Mohican Status Confirmed Priority Ultra High
Affected Products XR Windows, XR Linux
Description Textures are not display when using an old graphics card that do not support shader model 2.0 or higher. This means old computers that are playable on SFE are not playable with XR and the current Minimum Requirements are incorrect. We do not want to limit our user base in anyway shape or form if we can help it.

Here is an out take from a debug.log an effected computer:

==== START LOG SNIPPET ====
 
OpenGL: Vendor: NVIDIA Corporation
OpenGL: Renderer: GeForce4 MX 440/AGP/SSE2
OpenGL: Version: 1.5.7

...

--------------------------------------
- initializing GLSL
- Detecting supported Shader Model.....
- Shader Model 0 detected
- Sorry, no GLSL for you. (old card?)

==== END LOG SNIPPET ====
Attachment
*  shot00004yv5.png



Pages: [1] [2] [3]
Comments
DarknesS
Newerth Donator

on 2009-03-07 12:28:27

I tested this with my old Geforce 2 Mx and the textures also weren't displayed with it (see screenshot).

So if no one can fix this bug because you are missing access to the needed hardware to test it then I'd give it a try.
So if someone can give me access to a version of the source where this bug already occured I could *try* if I can fix it (Note: I'm pretty noob 3D Programming wise). Maybe spamming a bit OutputDebugString will already reveal if a ogl function fails...

----
OpenGL: Vendor: NVIDIA Corporation
OpenGL: Renderer: GeForce2 MX/AGP/SSE2
OpenGL: Version: 1.5.7
 

*  shot00113.png
Mohican
Order of the Stick
Former XR Dev

on 2009-03-29 23:01:17

Automated Messages:
The assignee of this bug has been changed to Mohican (Fr).

Admin Comment:
I have an old GeForce 2 knocking about.
I will build a PC this week using it, and I will try get this bug fixed.
Trust me! Moh
Zyxoma
Newerth Shoutcaster

on 2009-04-19 23:35:17

i have it too, and i have a newer graph card:
ati radeon hd2900
only sometimes, some servers it seems :S
DarknesS
Newerth Donator

on 2009-08-14 15:24:49

Come on guys fix it! This is the only bug that prevents xr-only servers since some ppl would end up playing without textures :/.

Team XR ftw!
biggeruniverse
Disrespectful Newerth Coder and Occasional Admin
Hero Member

on 2009-09-03 20:19:20

is this still a problem?
Mateus
Newbie

on 2009-10-03 21:18:16

Yep :/
Jermatoo
The New Guy
Newbie

on 2009-11-11 00:33:46

I have this issue at the moment.
Groentjuh
Newerth Serveradmin, German Mirror and Webdeveloper
Administrator

on 2010-01-24 16:49:16

still an issue btw
justux
Newbie

on 2010-01-26 17:56:00

hmmm...in savage... download godnest  java version

on 2010-02-02 12:23:40

it is still a problem. When y gonna fix it?
Pages: [1] [2] [3]
 
Post Comment
You need to login to post a comment
Personal Menu
Welcome, Guest. Please login below or register
 
 
140 Guests
0 Users
Please welcome AztechBlood, our newest member.
Become a Fan
Give us +1
Random Poll
What do you like most in any newly made maps?
Instant action!
Great looking scenery.
Balanced gameplay, long matches.
Niche gameplay, scripts!
Latest Image
Latest Image
Click to view
Shout Out Loud
Posted by Grantboy
Me waiting for 60 players in one server again be like... O_O
Posted by d00mer
TheBottle, ShameShifter, Ghimler, Botroth, UnclePhoe... nice botnames, drk %))
Posted by EpicIkaros
@Sas, join us on Discord - I think you'll get your answer quicker than on Newerth. Invitation link: https://discord.gg/gMXqMA7
Posted by SAS
hey, my savage stopped working. it worked just a couple of days ago. i start it, it checks for updates and then it just disappears, any idea?
Posted by EpicIkaros
It was never taken down, it's just hidden!
Log in to shout!