Main Menu
Savage XR
XR Development
Active Servers
You must enable javascript to see
this content!
Map of the Moment
XR Official Website
SavageXR.com
Teamspeak 3
You must enable javascript to see this content!
Bug Tracker
Viewing Bug #10: The Garbled Sound Bug
Category Savage Client Posted By Extreme Last Updated Sep 20, 2008
Assigned to Case Status Fixed Priority Very High
Affected Products Not Specified
Description Sound is garbled when starting matches.  Does not appear to happen to everyone, only some people.  May be related to increasing number of channels; will try decreasing number of available channels and see what happens.



Pages: [1] [2]
Comments

on 2008-07-24 08:18:44

The severity for this bug has been changed from 3 to 4 by Extreme
Django
Administrator

on 2008-07-30 11:44:41

I had to change the number of channels by hand. It might be a good idea to use new cvars for the sounds system so that saved values do not interfere with your defaults. This might be the cause of the issue since SFE uses a default of 196 (If I remember correctly)
Django
Administrator

on 2008-07-31 13:51:35

Darkbread commented on all other player units becoming invisible when this sound bug happens.

on 2008-07-31 13:51:40

The severity for this bug has been changed from 4 - Low to 3 - Normal by Django
Extreme
Modmaster General
Newbie

on 2008-08-11 22:31:34

Hmm... maybe even just making a cvar called sv_resetSoundSettings and setting it to 1 by default...  I just wish I had more time to look at it... this is a hell of a bug to track down

on 2008-08-12 14:14:31

The severity for this bug has been changed from 3 - Normal to 2 - Major by Django
Extreme
Modmaster General
Newbie

on 2008-08-13 09:24:25

I have seen the "invisible units" bug before (albeit with structures), but if I recall, my sound was fine at the time (I could be wrong...).  Maybe they are related, maybe not... this bug is so elusive...
Moxy
Newerth Donator

on 2008-08-17 13:43:07

I've never invisible units with Xr but this sound bug alwyas happen on the start after a restart, loading new map, starting a game. then after like 4/5 minutes the sound's are fine.
darkbread
Newerth Council

on 2008-08-27 14:33:00

fix it Sad
Senthryl
Code Poet
Full Member

on 2008-09-02 22:01:39

On my system it takes less than 4/5 minutes to solve it... usually around 2 minutes max.  But, I can confirm with almost certainty that the time it takes to fix itself is directly related to the number of sounds that play in the meantime.
Pages: [1] [2]
 
Post Comment
You need to login to post a comment
Personal Menu
Welcome, Guest. Please login below or register
 
 
106 Guests
0 Users
Please welcome oytjrigu, our newest member.
Become a Fan
Give us +1
Random Poll
What do you like most in any newly made maps?
Instant action!
Great looking scenery.
Balanced gameplay, long matches.
Niche gameplay, scripts!
Latest Image
Latest Image
Click to view
Shout Out Loud
Posted by FORTOCHKA(ua)
If you suffering from warp gold, than try o reconnect the servar until it gone. Just donate you lag before.
Posted by mutan
Posted by Precim
I like tomatoes with ketchup. :)))
Posted by Necrophiliac
If you suffering from warp lag, than try o reconnect the servar until it gone. Just donate you gold before.
Posted by d00mer
it seems like the harvest time has passed, so now THE farmers have to improve their skills ))
Log in to shout!