Welcome, Guest. Please login or register.
Did you miss your activation email?
August 15, 2020, 12:00:02 pm

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
190016 Posts in 11005 Topics by 18524 Members
Latest Member: h1ppy
* Home Forum Wiki Help Search Login Register
  Show Posts
Pages: [1]
1  Savage XR / Support Forum / Re: Savage wont start on: November 19, 2010, 08:58:49 pm
Could not find the command.

For the startup.cfg, do you mean in the .savage folder ... or in the folder it installs in? I tried adding it to the startup.cfg in the .savage folder, but it still did not work.

GLX is running, and the Nvidia driver installed a tool to changes the cards settings, which does work and is active. I've tried and was able to run Regnum Online.
2  Savage XR / Support Forum / Savage wont start on: November 19, 2010, 04:06:06 am
I just bought a new graphics card. I know it's not the best, gfx card ... I know that, but it's about 5 times better then my on board card. The problem I am having: Savage XR complains that it cannot find the GLX. I know I am running GLX because I can get the glxinfo

It's odd to me because I was just playing Assault Cube with maxed out resolution and I was playing Sauerbraten with maxed out resolution. GLX is there, savage is not able to find a matching visual.

My System:

OS: Fedora 13 64bit
Video: Galaxy GeForce GT 220 (Not great, but better than what I had)
CPU: Q6600 Quad
RAM: 4GB

debug.log
Quote
***********************************************************
Silverback Engine starting up...
[2010/11/18]
[20:56:24]
VERSION INFO
=====================================
(video res goes here)
Silverback build date: Aug 22 2010
Net Protocol: 12
Silverback XR

Version stamp is now OFF
running with glib version 2.16.6
masterserver.savage.s2games.com resolved to 216.127.51.199
freetype headers don't match binary! - compiled against 2.3.7!
---------------------------------------------------------
Vid_Init():
 * Adding mode 1: 1366x768x32
 * Adding mode 2: 1280x720x32
 * Adding mode 3: 1024x768x32
 * Adding mode 4: 832x624x32
 * Adding mode 5: 800x600x32
 * Adding mode 6: 700x525x32
 * Adding mode 7: 640x480x32
 * Adding mode 8: 512x384x32
 * Adding mode 9: 400x300x32
 * Adding mode 10: 320x240x32
attempting to set the following video mode: 1366 x 768 x 32 (32 bit depth buffer)
attempting to set the following video mode: 1366 x 768 x 32 (24 bit depth buffer)
attempting to set the following video mode: 1366 x 768 x 32 (16 bit depth buffer)
attempting to set the following video mode: 1366 x 768 x 16 (16 bit depth buffer)
attempting to set the following video mode: 1366 x 768 x 16 (16 bit depth buffer)
Couldn't set GL mode: Couldn't find matching GLX visual
3  Savage XR / Support Forum / Linux White Screen Issues on: July 07, 2010, 03:45:28 am
OS: Fedora 13 64bit
Video Card: Intel Series 4

I followed the advice to add vid_compress Textures 0 but I had to add it to the default.cfg in the settings folder. Then I could see a little more of the screen. I received a lot of these error messages in my debug.log


GL_RegisterShaderImageTextureMap: /gui/standard/black.s2g not found or bad shader
GL_RegisterShaderImageTextureMap: /gui/standard/black.s2g not found or bad shader
GL_RegisterShaderImageTextureMap: /gui/standard/black.s2g not found or bad shader


Am I missing something? Looks like I am missing the entire set of graphics.
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.014 seconds with 19 queries.