Welcome, Guest. Please login or register.
Did you miss your activation email?
May 08, 2021, 10:40:43 am

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
190085 Posts in 11010 Topics by 18598 Members
Latest Member: mootpoinT
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  Mac Installing Problems
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] Go Down Print
Author Topic: Mac Installing Problems  (Read 11903 times)
Mute_Killah
Newbie
*
Posts: 11



View Profile
« Reply #15 on: July 26, 2013, 10:23:24 pm »

Is it cause my mac isnt up to date?
Logged
Gunther
Newbie
*
Posts: 1


View Profile
« Reply #16 on: November 11, 2013, 03:50:16 am »

Hi, im not new to savage i played for about a year, not really known tho, but i tried to download 1.0 for the mac the other day and the download is successful and everything, but once i start it up it, it does what any other app would do on the mac, it shows up on the doc and jump, but once it starts to jump it just exits out and i get an error, the image is on the bottom of my post, but any help? I have a Mac OSX 10.5.8, i was able to play fine before idk what happened now, if anyone could help it would be really appreciated because i want to play again D:

I specifically joined this forum for the purpose of answering this question, so this had better work:

I am running a late 2011 iMac with Snow Leopard (10.6.8), and I was having exactly the same problem: It would barely jump in my dock, then crash and output the same error log.
The problem is permissions...or at least in my case.

Your SavageXR should be plainly installed in Application folder; go to Savage, bring up the Info window with Cmd. I, and at the bottom right you'll see a lock. You'll need administrator permissions to unlock it; do so, and then click the plus at the bottom left. Ideally, it should bring up a Contacts window that will have your account listed somewhere in it. Click on your account and Select/Add, and it should add your account to the list in the Savage Info window. If your account isn't listed in the Contacts window, try fiddling around with "New Person" in the same window; I haven't needed to mess with that.
Now that you've added your name to the Savage Info window list, click the drop down on the same line as your name and set it to "Read & Write".
Close the window, then right click SavageXR and hit "Show Package Contents". Inside you'll see a folder called, well, Contents. Right click that folder and repeat the above process to add your name and Read/Write privileges to the Contents folder Info window. Then click the gear at the bottom of the Contents info window to bring up the menu, then click what should say "Apply to Contents" to apply the permissions to every file inside the Contents folder, thereby making it possible to write to the game and use the auto-updater…thereby allowing you to run the game.

This was tested on Snow Leopard, so, it should be the same for your system.
Hope this helps all future clients with this problem.
« Last Edit: November 11, 2013, 03:53:30 am by Gunther » Logged
Rostner
The Grapist
Full Member
***
Posts: 144


I'm gonna grape you in the mouth!!!


View Profile WWW
« Reply #17 on: November 11, 2013, 02:47:03 pm »

Holy cow I can't believe I never thought of looking at the permissions. Thanks so much Gunther.  Afro

I think that someone should post this 'how-to' with the mac download link, because this happened to me as well, and I'm using OS X Mavericks 10.9.
Logged

Pages: 1 [2] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.022 seconds with 20 queries.