Welcome, Guest. Please login or register.
Did you miss your activation email?
May 23, 2017, 06:13:42 am

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
188068 Posts in 10826 Topics by 17844 Members
Latest Member: BronyCringe
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  REPORT: Linux Savage XR Bugs
0 Members and 2 Guests are viewing this topic. « previous next »
Pages: 1 [2] 3 4 ... 15 Go Down Print
Author Topic: REPORT: Linux Savage XR Bugs  (Read 99642 times)
big_tower
Full Member
***
Posts: 159


throughout a 'Son of Newerth'


View Profile
« Reply #15 on: April 29, 2009, 02:25:09 pm »

Code:
************************************************************
Silverback Engine starting up...
[2009/04/26]
[17:56:29]
VERSION INFO
=====================================
(video res goes here)
Silverback build date: Apr 18 2009
Net Protocol: 12
Silverback XR

Version stamp is now OFF
running with glib version 2.12.4
masterserver.savage.s2games.com resolved to 216.127.51.199
freetype headers don't match binary! - compiled against 2.2.1!
---------------------------------------------------------
Vid_Init():
 * Adding mode 1: 1600x1200x32
 * Adding mode 2: 1280x1024x32
 * Adding mode 3: 1152x864x32
 * Adding mode 4: 1024x768x32
 * Adding mode 5: 832x624x32
 * Adding mode 6: 800x600x32
 * Adding mode 7: 720x400x32
 * Adding mode 8: 640x480x32
attempting to set the following video mode: 1024 x 768 x 32 (32 bit depth buffer)
attempting to set the following video mode: 1024 x 768 x 32 (24 bit depth buffer)
Screen Res: 1024 x 768
Screen BPP: 32
Depth Buffer Size: 24

Vendor     : DRI R300 Project
Renderer   : Mesa DRI R300 20060815 AGP 8x x86/MMX+/3DNow!+/SSE TCL
Version    : 1.3 Mesa 7.4
Extensions : GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow_ambient GL_SUN_multi_draw_arrays

SDL_GL_RED_SIZE: requested 8, got 8
SDL_GL_GREEN_SIZE: requested 8, got 8
SDL_GL_BLUE_SIZE: requested 8, got 8
SDL_GL_DEPTH_SIZE: requested 32, got 24
SDL_GL_DOUBLEBUFFER: requested 1, got 1
Anti-aliasing not enabled
Using mode 4: 1024x768x32
OpenGL: Vendor: DRI R300 Project
OpenGL: Renderer: Mesa DRI R300 20060815 AGP 8x x86/MMX+/3DNow!+/SSE TCL
OpenGL: Version: 1.3 Mesa 7.4
OpenGL: Extensions: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_

When I start up with the terminal its showing this lines (in the terminal):
GameInit()
LostFocus

Sorry I forgot and here's a Screenshot too:


The white square represents the cursor.

Thx for your time! Appreciated!
Logged

giner
Newbie
*
Posts: 22


View Profile
« Reply #16 on: May 17, 2009, 12:29:12 pm »

Savage XR Doesn't start. It was broken today after update.

LD_LIBRARY_PATH="lib:$LD_LIBRARY_PATH" ./savage.bin
./savage.bin: /usr/lib/libcurl.so.4: no version information available (required by ./savage.bin)
System_Init()
PNG header and library versions do not match
Logged
Voodoo Vood
Newbie
*
Posts: 5



View Profile
« Reply #17 on: May 17, 2009, 01:51:12 pm »

hi all,

me system: linux gentoo

at last update crash me XR:

~/savage-xr $ ./silverback.bin
./silverback.bin: /usr/lib/libcurl.so.4: no version information available (required by ./silverback.bin)
System_Init()
PNG header and library versions do not match
~/savage-xr $

thx
Logged
giner
Newbie
*
Posts: 22


View Profile
« Reply #18 on: May 17, 2009, 02:32:22 pm »

My TEMPORARY solution (work around) is donwgrade to revision 2537 (now 2538):

1. file savage-xr/au.cfg: change
isTesting "0" to
isTesting "1"
2. remove file:
savage-xr/autoupdater/localversion/version.txt
3. run:
savage.sh
4. If error happen during update you should run it again.
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #19 on: May 17, 2009, 07:32:18 pm »

My TEMPORARY solution (work around) is donwgrade to revision 2537 (now 2538):

1. file savage-xr/au.cfg: change
isTesting "0" to
isTesting "1"
2. remove file:
savage-xr/autoupdater/localversion/version.txt
3. run:
savage.sh
4. If error happen during update you should run it again.


That changes your savage install to use the unstable testing client where we have the issued fixed. We'll be merging the fix into the production install, that you download of this website, asap. I advise against using isTesting as it will mean that your running a client with files from two different versions of the game with unknown consequence, but if you don't mind reinstalling in a few days when the fix is live then its not an issue.
Logged
giner
Newbie
*
Posts: 22


View Profile
« Reply #20 on: May 17, 2009, 07:59:15 pm »

My TEMPORARY solution (work around) is donwgrade to revision 2537 (now 2538):

1. file savage-xr/au.cfg: change
isTesting "0" to
isTesting "1"
2. remove file:
savage-xr/autoupdater/localversion/version.txt
3. run:
savage.sh
4. If error happen during update you should run it again.


That changes your savage install to use the unstable testing client where we have the issued fixed. We'll be merging the fix into the production install, that you download of this website, asap. I advise against using isTesting as it will mean that your running a client with files from two different versions of the game with unknown consequence, but if you don't mind reinstalling in a few days when the fix is live then its not an issue.
After all I returned isTesting to 0 and ran update again. Now it works, but new installation (from bin, without other strange manipulations) after update doesn't work.
Logged
Asami
Newbie
*
Posts: 2


View Profile
« Reply #21 on: May 21, 2009, 02:16:45 pm »

I'm getting the PNG header error without the libcurl error.

Whenever I start Savage XR I get the following:
Code:
anthony@Asami:~/.games/savage-xr$ ./savage.sh
System_Init()
PNG header and library versions do not match
Signal
anthony@Asami:~/.games/savage-xr$
Logged
Paavo
Guest
« Reply #22 on: May 21, 2009, 03:16:28 pm »

Not actually an bug, but still, I need help with this one.

So I have newest version of Mepis, (don't remember what was it) and it's 64 bit. I downloaded Savage XR and launched it but there is an error what says: "Cannot connect to server. Please check your network connection and firewall blah blah". I can freely work on internet browsers, but games will not connect anywhere ;(.

-My Mepis has no firewall
-I'm using wireless network with KNetWorkManager.
-Mepis is 64 bit
-I have installed Savage XR correctly.
-Halp. ;(
Logged
Chiprel
Hero Member
*****
Posts: 539



View Profile
« Reply #23 on: May 21, 2009, 03:20:45 pm »

Asami:
Dunno if this will help or not.
Was using Ubuntu one year ago(for some Uni project) don't remember exactly what I did to make sav(sfe) working but I used:
Use getlibs:

http://ubuntuforums.org/showthread.php?t=474790

use the command ldd on silverback.bin to find the version of libpng and download it with getlibs should solve your issue Smiley
ldd to find out about png lib version in savage. Then I downloaded that lib version or maybe a bit newer-basicaly by googling it. (getlib for that lib wasn't working Sad )
If you get savage to work on your PC it would be nice if you posted what you did(and post link to that working lib so maybe some admin could put it in savage linux download section)  Afro

Paavo:
Are you at home or at work? Maybe you have some ports blocked?
Try opening ports I posted some days ago: http://www.newerth.com/smf/index.php/topic,7070.0.html
« Last Edit: May 21, 2009, 03:29:37 pm by Chiprel » Logged

kog
Newbie
*
Posts: 7


View Profile
« Reply #24 on: May 21, 2009, 07:48:14 pm »

I'm getting the PNG header error without the libcurl error.

Whenever I start Savage XR I get the following:
Code:
anthony@Asami:~/.games/savage-xr$ ./savage.sh
System_Init()
PNG header and library versions do not match
Signal
anthony@Asami:~/.games/savage-xr$

I'm getting the same error :/
Logged
Asami
Newbie
*
Posts: 2


View Profile
« Reply #25 on: May 21, 2009, 08:28:35 pm »

Asami:
Dunno if this will help or not.
Was using Ubuntu one year ago(for some Uni project) don't remember exactly what I did to make sav(sfe) working but I used:
Use getlibs:

http://ubuntuforums.org/showthread.php?t=474790

use the command ldd on silverback.bin to find the version of libpng and download it with getlibs should solve your issue Smiley
ldd to find out about png lib version in savage. Then I downloaded that lib version or maybe a bit newer-basicaly by googling it. (getlib for that lib wasn't working Sad )
If you get savage to work on your PC it would be nice if you posted what you did(and post link to that working lib so maybe some admin could put it in savage linux download section)  Afro
Getlibs says the dependencies are satisfied. I'm not sure what precisely the problem *is* though. Is it a problem with the libs in the game folder or the libs in my system? If the latter, why would the game not be working without this one specific version of libpng?(I'd rather not mess around with my system libraries, understandably.)
Also, are there any workarounds/guides to fix it in the meantime?
Logged
borkbork
Newbie
*
Posts: 4


View Profile
« Reply #26 on: May 22, 2009, 10:52:37 am »

I've got the same issue as Paavo.
I've built a new box and installed Ubuntu 9.04 64bit version on it. Installed Savage XR from fine, but when I launch it i get:
Code:
ERROR: Failed to contact update server!
Please check your internet connection and firewall and restart the application to get the latest updates.
Would you like to launch the application anyway?
Tested on the old box (8.04/32bit) and is still updating there, so it's not the update servers. Does anyone know why it would fail under 64bit version?  I suspect it's something to do with the libraries in the savage-xr/lib folder, and I even went as far as trying to replace the files in ./lib with copies of my system libraries, with no luck.

Also, downloads of custom maps fail when I connect to a server in the game. Connecting to servers with the standard maps is ok.
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #27 on: May 22, 2009, 02:35:41 pm »

I'll look into these issues at the weekend. Most likely related to problems with the libcurl library.
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #28 on: May 23, 2009, 07:05:02 pm »

A new linux installer will be available in about an hour to fix the issues people are experiencing with the libraries. Unfortunately the problem can't be resolved via the auto updater as it is also affected. The autoupdater is unable to replace the library libstdc++.so.6 and crashes when doing so. Strange behaviour as other libraries that have been updated do not cause this problem. Frustrating!
Logged
Paavo
Guest
« Reply #29 on: May 23, 2009, 08:11:59 pm »

Paavo:
Are you at home or at work? Maybe you have some ports blocked?
Try opening ports I posted some days ago: http://www.newerth.com/smf/index.php/topic,7070.0.html
Didn't quite understand that post, do you know a command what will open all ports? I tried some kind of   man nc   and
nc -l portnumber
Logged
Pages: 1 [2] 3 4 ... 15 Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.044 seconds with 19 queries.