Welcome, Guest. Please login or register.
Did you miss your activation email?
November 22, 2017, 01:07:12 pm

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
188629 Posts in 10884 Topics by 17943 Members
Latest Member: Dawnbringer
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  libgpg-error when starting the game / updating worked
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: libgpg-error when starting the game / updating worked  (Read 711 times)
MaoDelinSc
Newbie
*
Posts: 1


View Profile
« on: March 31, 2017, 12:03:41 am »

Hey there,

I am quite the Linux noob so I have no idea what to do now, Google didn't help anymore Sad

My system:

Processor      : 2x Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
Memory      : 3999MB (1321MB used)
Operating System      : Linux Mint 18.1 Serena
OpenGL Renderer      : Mesa DRI Mobile Intel® GM45 Express Chipset
X11 Vendor      : The X.Org Foundation

Kernel      : Linux 4.10.7-041007-generic (x86_64)
Compiled      : #201703300510 SMP Thu Mar 30 09:12:35 UTC 2017
C Library      : Unknown
Default C Compiler      : GNU C Compiler version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4)
Desktop Environment      : X-Cinnamon (cinnamon)

I downloaded and installed via xr_setup-1.0rc3-cl_lin_prod.bin which I got on this website. I made savage.sh executable and ran it, everything worked just fine, somewhat 500 MB of an update went through, the program closed and - that was it. I restarted savage.sh and the program very briefly displayed "No updates detected. Starting Application" and then closed again.

So I ran it through the terminal and got some error messages:



I googled the libgpg no version available message and retrieved this post here: http://askubuntu.com/questions/624486/libgpg-error-so-0-no-version-information-available

I don't have any local libgpg library as the answer there suggested. With the commands above I got the version number and everything:



Do you have any ideas? I'd be very grateful Smiley
Logged
drk
Newerth Council
Sr. Member
*
Posts: 487



View Profile
« Reply #1 on: March 31, 2017, 07:54:58 am »

I made savage.sh executable and ran it, everything worked just fine, somewhat 500 MB of an update went through
Do you mean game update? When did you get that update? As far as I know xr 1.3 is not out yet. Just wondering what is that kind of an update because I suppose that savage.sh every time checks for an updates. Or was it your first (old) update since you've installed savage?
errors
I didn't try linux client but I think that I'd try to check if the libgpg is x32 (i386).
Also if the problem is in x86 - 64 from that I've done to my ubuntu server to let it run x86
Code:
# Running x32 apps on x64 Ubuntu:
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
I'm not sure but also check does your /libs folder contain that gpg .so ? If it's not there you can try to download and put it there (https://launchpad.net/ubuntu/+source/libgpg-error)
« Last Edit: March 31, 2017, 08:11:02 am by drk » Logged

Groentjuh
Newerth Serveradmin, German Mirror and Webdeveloper
Administrator
Super Hero Member
*****
Posts: 1351


View Profile WWW
« Reply #2 on: March 31, 2017, 08:47:36 am »

Do you mean game update? When did you get that update? As far as I know xr 1.3 is not out yet. Just wondering what is that kind of an update because I suppose that savage.sh every time checks for an updates. Or was it your first (old) update since you've installed savage?
That was his first update. So yea, 500MB sounds about right. The installers are ancient.
Logged


Before adding any of my IMs, ask yourself: Can I ask it in a PM?
Before sending me a PM with questions, Search the forums!
Wanna be ref? Post on my Server Forum
Hakugei
XR Coder
Legendary Member
***
Posts: 3745



View Profile
« Reply #3 on: March 31, 2017, 12:47:20 pm »

The installers are ancient.
I downloaded and installed via xr_setup-1.0rc3-cl_lin_prod.bin which I got on this website.
Especially the RC3 version.
Which may or may not be causing an error, despite using the same updates.
(I've never tried updating to post-1.0 with RC3, so I don't know if this is actually a problem.)
Logged
Adriaan
Newbie
*
Posts: 3


View Profile
« Reply #4 on: March 31, 2017, 01:33:37 pm »

Hello & welcome, MaoDelinSc

"libs/libgpg-error.so.0: no version information available"

is not an error but rather a warning in the sense that it's non-critical and can essentially be ignored
the reason you crash is because there's a binary incompatibility between various .so file in your system and the libs pre-packaged by savage. the whole world moved on but savage still links against ancient library versions.

you can solve this by going to savage/libs/ folder and deleting "libstdc++.so.6"
savage is pretty stubborn about its libs folder so it will redownload the deleted .so files every time there's an update (if that ever happens after 1.3  You Ugly & Stupid), so you will have to delete the file every time

hf Smiley
« Last Edit: March 31, 2017, 01:39:09 pm by Adriaan » Logged
biggeruniverse
Disrespectful Newerth Coder and Occasional Admin
Hero Member
*****
Posts: 929


Savage Days


View Profile
« Reply #5 on: April 02, 2017, 04:49:12 am »

Sigh. Ignore all the people above, they completely missed the actual problem.  Undecided

Looks like you're running on a laptop. You've got an embedded Intel graphics card:

Quote
OpenGL Renderer      : Mesa DRI Mobile Intel® GM45 Express Chipset

However, you're failing to load drivers for DRI:

Quote
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: unable to load driver: i965
libGL error: unable to load driver: swrast_dri.so

So start looking around for how to fix that for your flavor of Linux.
Logged


https://twitter.com/SavageRebirth
Quote from: Helios
You mean an already 7 yr old game is going to die eventually?  Good call there Nostradumbass
Adriaan
Newbie
*
Posts: 3


View Profile
« Reply #6 on: April 02, 2017, 11:03:50 am »

Sigh. Ignore all the people above, they completely missed the actual problem.  Undecided

Looks like you're running on a laptop. You've got an embedded Intel graphics card:

Quote
OpenGL Renderer      : Mesa DRI Mobile Intel® GM45 Express Chipset

However, you're failing to load drivers for DRI:

Quote
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: unable to load driver: i965
libGL error: unable to load driver: swrast_dri.so

So start looking around for how to fix that for your flavor of Linux.


Download Mint and install it in a VM, you'll keep crashing as long libstdc++ is still present in libs/ folder with "ligGL" errors,
ldd i965_dri.so or swrast_dri.so and maybe you'll realize something  Rolleyes so yah thats still step #1
« Last Edit: April 02, 2017, 11:20:05 am by Adriaan » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.052 seconds with 19 queries.