Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2017, 11:17:42 am

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
188605 Posts in 10883 Topics by 17932 Members
Latest Member: MrStoner
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  Mouse tracking / Input lag?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Mouse tracking / Input lag?  (Read 831 times)
Sorel
Clan Representative
Newbie
*
Posts: 19


View Profile
« on: April 02, 2016, 02:58:53 am »

Hey guys,

I seem to be having a major problem atm. Basically, when I move my mouse side to side in game it tracks fairly smoothly. However, as soon as I use the keyboard to enter another input (eg. WASD movement, tab to view scores, space for jump etc.) the camera begins to move extremely erratically as though the mouse is experiencing some sort of severe input lag. It drags and then suddenly jumps to where it should be looking. The delay isn't constant.

The problem started this evening. Tested it with a few different mice and the touchpad. As far as I can tell (just ran a couple of simple tests in paint to check for skipping, jitter etc.) I don't seem to have this problem outside of the game. I tested it in 3 servers (Martial Arena, United MA, and Pulse) and it happened in all of them. It starts as soon as I enter the game, including in the unit selection screen, but not in previous menus.

Any help troubleshooting would be appreciated. Smiley
« Last Edit: April 02, 2016, 04:24:21 am by Sorel » Logged
Nanaa
Newerth Donator
Hero Member
****
Posts: 626



View Profile WWW
« Reply #1 on: April 02, 2016, 10:01:41 am »

Not sure if related to your problem but try

Code:
host_maxfps 120

It caps your max fps below 125.
Logged
Daemon
XR Main Developer
Legendary Member
****
Posts: 4721


beware, for this is the everbroken...


View Profile
« Reply #2 on: April 02, 2016, 01:21:28 pm »

Not sure if related to your problem but try

Code:
host_maxfps 120

It caps your max fps below 125.

If that doesn't work, try a value of 999 (remember to pull down console and write the command there).
Logged

Sorel
Clan Representative
Newbie
*
Posts: 19


View Profile
« Reply #3 on: April 02, 2016, 03:56:03 pm »

I tried host_maxfps 120.

It partly worked. It prevents some of the more erratic movements, but there's still a significant jitter. If I turn smoothly then every couple of seconds or so it will jump by about 10-20 degrees. If I move forwards and move the mouse backwards and forwards smoothly over a tiny area (essentially gently wobbling the view point while staying in the same direction) the jumps are still large enough and frequent enough that I can end up facing completely the opposite direction before making it across a short distance (for instance middle of the duel garden). Melee and aiming are both extremely difficult like this, as I'm constantly battling the cursor. I've tried a bunch of different dps and sensitivity settings and nothing seems to work.

host_maxfps 999 didn't seem to do anything.

Going to try reinstalling the game and my mouse drivers. Tried this. It didn't work.

Any other advice would be really helpful.
« Last Edit: April 02, 2016, 07:11:44 pm by Sorel » Logged
Sorel
Clan Representative
Newbie
*
Posts: 19


View Profile
« Reply #4 on: April 02, 2016, 11:14:40 pm »

Fixed. Turned out the stutter was related to CPU consumption. I had some programs that bugged out when closing down and were taking up 60-70% of my processing power. It's a shitty laptop so that was enough to stop the game running properly. Oddly enough it continued after rebooting a couple of times.

I only noticed that it was a performance issue when I went into a large public game and had a notable fps hit, which didn't show up when I was testing in duels. I have no idea why a cpu hit affected the input from my mouse but caused virtually no stutter in the smoothness of animations, but there you go. Problem solved. Host_maxfps 120 also helped.

Thanks for the responses guys.
« Last Edit: April 03, 2016, 02:28:11 am by Sorel » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.044 seconds with 19 queries.