Welcome, Guest. Please login or register.
Did you miss your activation email?
March 30, 2017, 01:45:26 pm

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
187605 Posts in 10789 Topics by 17799 Members
Latest Member: Demonhunted
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  TUTORIAL: Installing Savage XR on 64-bit Ubuntu 14.04
0 Members and 2 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: TUTORIAL: Installing Savage XR on 64-bit Ubuntu 14.04  (Read 6329 times)
Posts: 9

View Profile
« on: November 27, 2014, 12:46:54 am »

How to Install Savage XR on 64-bit Ubuntu 14.04


I made some big progress recently in getting Savage XR running on my Ubuntu 14.04 LTS 64-bit laptop, when previously I couldn't even figure out how to install it. The process is far more complicated than on Windows, Mac, or older Ubuntu versions, where you simply download the installer file and double-click it; on 64-bit Ubuntu, you need to install additional dependencies first. So I'm now going to write out the steps I did to make it work in case they help anyone else (or in case my laptop crashes and I need steps to install it again!).

This guide will walk you through the process of installing and running Savage XR 1.0 on your 64-bit Ubuntu 14.04 computer. At present, the process is not very simple and requires many steps; this is because the game is currently 32-bit and Canonical has changed how Ubuntu supports 32-bit programs on 64-bit computers (specifically, the "ia32-libs" package is now deprecated). Hopefully, this guide will make the process easier and faster for you to start playing Savage XR. And hopefully we'll have a 64-bit version of the game sometime in the future to make things dead-simple.

Requirements & Preparation

This guide is specific to Ubuntu 14.04 LTS running on 64-bit processors. It's likely that it also applies to Ubuntu 13.10 too. I can't vouch for other GNU/Linux operating systems because I don't use them.

If you're using a 32-bit computer, a much older version of Ubuntu, or an entirely different GNU/Linux distribution, then this guide most likely won't apply because your system will likely run 32-bit programs without needing additional dependencies. If you're running a distribution other than Ubuntu, such as Debian, Arch, Fedora, Gentoo, etc. and you can't get Savage working, then you can try these steps but they may not work.

Also, you'll need to be comfortable using the Terminal command-line interface to follow this guide. It's currently not possible to get Savage XR running on Ubuntu without using Terminal. If you don't know how to use Terminal, you'll have to either learn to use it or wait and hope that future versions of the game become easier to run (ie. for Savage to become 64-bit instead of 32-bit).

I recommend you make a backup of your system before following this guide. You're unlikely to cause any harm to your computer, but a backup helps just in case, especially if you're new to Ubuntu or Terminal. You follow this guide at your own risk.

General system requirements for playing Savage XR are here.

Installation Steps

1. Download the Savage XR GNU/Linux installer file

You can download the installer from either of these pages:

Take note of where you saved the file on your hard drive. The following steps will assume it's located in "/home/yourusername/Downloads", which is the default location for Firefox on Ubuntu. You may need to substitute a different path if your browser saves to a different folder.

2. Install "lib32nss-mdns"

By default in Ubuntu 14.04 on 64-bit systems, the game installer file will not execute at all, even if you make it executable. Double-clicking it won't work, nor will executing it from the Terminal. This is because it also requires extra packages to be on your system in order to run, which are not present by default. The installer requires the "lib32nss-mdns" package and its dependencies.

Here's what you do in Terminal: navigate to the installer file and use "chmod +x" to make it executable, install the "lib32nss-mdns" package and dependencies by using "sudo apt-get install", then run the installer file by using "./[filename]".
drfunko@ubuntu:~$ cd Downloads
drfunko@ubuntu:~/Downloads$ ls
drfunko@ubuntu:~/Downloads$ chmod +x xr_setup-1.0-cl_lin_prod.bin
drfunko@ubuntu:~/Downloads$ sudo apt-get install lib32nss-mdns
drfunko@ubuntu:~/Downloads$ ./xr_setup-1.0-cl_lin_prod.bin

After you enter the last command above, follow the prompts and then Savage XR will be installed. You'll be asked to confirm whether you want to install Savage XR and where you want to install it on your hard drive (by default it's /home/yourusername/savage-xr).

If you try to run your newly-installed Savage XR at this point, it won't work. Nothing will happen. You've dealt with the package needed to run the installer, but it turns out there are more system files/packages needed to actually run the game. They also aren't on your computer by default, so you need to install them.

3. Use "ldd" to look for missing system files

To find out which files are needed, you can run the ldd command on Savage's three main binary files: a-u.bin, savage.bin, and silverback.bin. In Terminal, navigate to the folder where you installed Savage, then run ldd on the three binaries:
drfunko@ubuntu:~/Downloads$ cd ../savage-xr
drfunko@ubuntu:~/savage-xr$ ls
a-u.bin      editor.sh  help      newerth.xpm  silverback.bin  uninst.xpm
au.cfg       game       icon.xpm  savage.bin   tools
autoupdater  graveyard  libs      savage.sh    uninstall.bin
drfunko@ubuntu:~/savage-xr$ ldd a-u.bin
drfunko@ubuntu:~/savage-xr$ ldd savage.bin
drfunko@ubuntu:~/savage-xr$ ldd silverback.bin

The ldd commands will output lists of all the files required for the binaries to run, many of which are already installed by default in Ubuntu 14.04, some of which are not. As an example, you may see output like the text below. (Note that this output is specific to my computer. The output on your computer may be different.)
drfunko@ubuntu:~/savage-xr$ ldd a-u.bin
linux-gate.so.1 =>  (0xf7791000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf775a000)
libcurl.so.4 => not found
libz.so.1 => not found
libfltk.so.1.1 => not found
libfltk_images.so.1.1 => not found
libXpm.so.4 => not found
libstdc++.so.6 => not found
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7712000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf76f5000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7546000)
/lib/ld-linux.so.2 (0xf7792000)
libX11.so.6 => not found
drfunko@ubuntu:~/savage-xr$ ldd savage.bin
linux-gate.so.1 =>  (0xf77c1000)
libstdc++.so.6 => not found
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7760000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7742000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7593000)
/lib/ld-linux.so.2 (0xf77c2000)
drfunko@ubuntu:~/savage-xr$ ldd silverback.bin
linux-gate.so.1 =>  (0xf77a4000)
libglib-2.0.so.0 => not found
libpng12.so.0 => ./libs/libpng12.so.0 (0xf7765000)
libSDL-1.2.so.0 => not found
libz.so.1 => ./libs/libz.so.1 (0xf774f000)
libjpeg.so.62 => ./libs/libjpeg.so.62 (0xf7730000)
libfreetype.so.6 => not found
libcurl.so.4 => ./libs/libcurl.so.4 (0xf76ec000)
libfmodex.so => ./libs/libfmodex.so (0xf753c000)
libGL.so.1 => not found
libGLU.so.1 => not found
libbz2.so.1.0 => not found
libstdc++.so.6 => ./libs/libstdc++.so.6 (0xf744e000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7407000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf73ea000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf723b000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7236000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf721a000)
libcrypto.so.0.9.8 => ./libs/libcrypto.so.0.9.8 (0xf70bc000)
libX11.so.6 => not found
libidn.so.11 => ./libs/libidn.so.11 (0xf708b000)
libssh2.so.1 => ./libs/libssh2.so.1 (0xf706a000)
liblber-2.4.so.2 => ./libs/liblber-2.4.so.2 (0xf705c000)
libldap_r-2.4.so.2 => ./libs/libldap_r-2.4.so.2 (0xf7019000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7010000)
libgssapi_krb5.so.2 => ./libs/libgssapi_krb5.so.2 (0xf6fe6000)
libssl.so.0.9.8 => ./libs/libssl.so.0.9.8 (0xf6fa0000)
/lib/ld-linux.so.2 (0xf77a5000)
libgcrypt.so.11 => ./libs/libgcrypt.so.11 (0xf6f37000)
libgpg-error.so.0 => ./libs/libgpg-error.so.0 (0xf6f33000)
libnsl.so.1 => /lib/i386-linux-gnu/libnsl.so.1 (0xf6f1a000)
libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xf6f02000)
libsasl2.so.2 => ./libs/libsasl2.so.2 (0xf6eeb000)
libgnutls.so.26 => ./libs/libgnutls.so.26 (0xf6e4d000)
libkrb5.so.3 => ./libs/libkrb5.so.3 (0xf6db9000)
libk5crypto.so.3 => ./libs/libk5crypto.so.3 (0xf6d95000)
libcom_err.so.2 => ./libs/libcom_err.so.2 (0xf6d92000)
libkrb5support.so.0 => ./libs/libkrb5support.so.0 (0xf6d89000)
libkeyutils.so.1 => ./libs/libkeyutils.so.1 (0xf6d86000)
libtasn1.so.3 => ./libs/libtasn1.so.

In the following steps, you'll be installing all the files that say "not found" in the output lists above, the rest are already installed and you can ignore them.

Read through the output text and write a list of all the files that the ldd commands say are "not found" for a-u.bin, savage.bin, and silverback.bin. If you find duplicates in this list, you can remove the extra ones; this happens because the three binary files have some overlapping requirements. From the output above, the list of "not found" files would look like the one below. (This is the list of files I need on my computer according to the ldd output above. Yours might be different, so make sure you actually run the ldd commands to determine what you need.)
libcurl.so.4 => not found
libz.so.1 => not found
libfltk.so.1.1 => not found
libfltk_images.so.1.1 => not found
libXpm.so.4 => not found
libstdc++.so.6 => not found
libX11.so.6 => not found
libglib-2.0.so.0 => not found
libSDL-1.2.so.0 => not found
libfreetype.so.6 => not found
libGL.so.1 => not found
libGLU.so.1 => not found
libbz2.so.1.0 => not found

4. Use "dpkg" to determine which packages you need

The files in the list you made in the previous step are files, they are not packages. You can't simply obtain the raw individual files, it doesn't work that way. You need to get the packages that contain the files. This next step is to determine which packages contain the files on your list. The "dpkg" tool is a package manager that can be used to search packages for files.

In Terminal, use "dpkg -S [FILENAME]" for each of the files in your list. Note that the "-S" in the command is an upper case S. (Again, the files seen in the example below are specific to my system. Do not simply copy/paste the exact commands in this example, run the "ldd" commands above to determine a list of files that are missing on your particular system.)
drfunko@ubuntu:~/savage-xr$ dpkg -S libcurl.so.4
libcurl3:amd64: /usr/lib/x86_64-linux-gnu/libcurl.so.4
libcurl3:amd64: /usr/lib/x86_64-linux-gnu/libcurl.so.4.3.0
drfunko@ubuntu:~/savage-xr$ dpkg -S libz.so.1
zlib1g:amd64: /lib/x86_64-linux-gnu/libz.so.1.2.8
zlib1g:amd64: /lib/x86_64-linux-gnu/libz.so.1
drfunko@ubuntu:~/savage-xr$ dpkg -S libfltk.so.1.1
dpkg-query: no path found matching pattern *libfltk.so.1.1*
drfunko@ubuntu:~/savage-xr$ dpkg -S libfltk_images.so.1.1
dpkg-query: no path found matching pattern *libfltk_images.so.1.1*
drfunko@ubuntu:~/savage-xr$ dpkg -S libXpm.so.4
libxpm4:amd64: /usr/lib/x86_64-linux-gnu/libXpm.so.4
libxpm4:amd64: /usr/lib/x86_64-linux-gnu/libXpm.so.4.11.0
drfunko@ubuntu:~/savage-xr$ dpkg -S libstdc++.so.6
libstdc++6:amd64: /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.19
libstdc++6:amd64: /usr/lib/x86_64-linux-gnu/libstdc++.so.6
drfunko@ubuntu:~/savage-xr$ dpkg -S libX11.so.6
libx11-6:amd64: /usr/lib/x86_64-linux-gnu/libX11.so.6.3.0
libx11-6:amd64: /usr/lib/x86_64-linux-gnu/libX11.so.6
drfunko@ubuntu:~/savage-xr$ dpkg -S libglib-2.0.so.0
libglib2.0-0:amd64: /lib/x86_64-linux-gnu/libglib-2.0.so.0
libglib2.0-0:amd64: /lib/x86_64-linux-gnu/libglib-2.0.so.0.4000.0
drfunko@ubuntu:~/savage-xr$ dpkg -S libSDL-1.2.so.0
libsdl1.2debian:amd64: /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0.11.4
libsdl1.2debian:amd64: /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0
drfunko@ubuntu:~/savage-xr$ dpkg -S libfreetype.so.6
libfreetype6:amd64: /usr/lib/x86_64-linux-gnu/libfreetype.so.6
libfreetype6:amd64: /usr/lib/x86_64-linux-gnu/libfreetype.so.6.11.1
drfunko@ubuntu:~/savage-xr$ dpkg -S libGL.so.1
libgl1-mesa-glx:amd64: /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
libgl1-mesa-glx:amd64: /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0
drfunko@ubuntu:~/savage-xr$ dpkg -S libGLU.so.1
libglu1-mesa:amd64: /usr/lib/x86_64-linux-gnu/libGLU.so.1
libglu1-mesa:amd64: /usr/lib/x86_64-linux-gnu/libGLU.so.1.3.1
drfunko@ubuntu:~/savage-xr$ dpkg -S libbz2.so.1.0
libbz2-1.0:amd64: /lib/x86_64-linux-gnu/libbz2.so.1.0
libbz2-1.0:amd64: /lib/x86_64-linux-gnu/libbz2.so.1.0.4

The output of these dpkg commands contains the names of the packages you need to install in order to obtain the files on the list you made from the ldd commands in step 3. For each one, the part just before ":amd64" is the name of the package.

Also, in the example above, you can see the two searches for "libfltk.so.1.1" and "libfltk_images.so.1.1" failed to produce results. Without going into excessive detail, I can tell you that the package name for both these files is "libfltk1.1". (If you run into other files that similarly produce no search results with dpkg, or if you're really interested in more detailed package searching, try installing the "apt-file" tool with "sudo apt-get-install apt-file" and then doing searches with the command "apt-find search [filename]".)

Make a list of all the package names. From the output above, the list of packages would look like this:

5. Install the missing packages with "apt-get"

Now that you have a list of packages that contain the files you're missing, you can begin installing them. However, you need the 32-bit versions of these packages, not the regular 64-bit ones. This is because Savage XR is a 32-bit program.

In Terminal, you can use "sudo apt-get install" to install the packages and append ":i386" to the end of the package names to get the 32-bit versions. You can even install all the packages at once by writing them into a single long command like this:
drfunko@ubuntu:~/savage-xr$ sudo apt-get install libcurl3:i386 zlib1g:i386 libfltk1.1:i386 libxpm4:i386 libstdc++6:i386 libx11-6:i386 libglib2.0-0:i386 libsdl1.2debian:i386 libfreetype6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libbz2-1.0:i386

You'll likely have to wait a little while for all the packages and their dependencies to download and install.

6. Test running Savage XR

You should now have all the files/packages necessary to run Savage XR. There are two easy ways to run it: using the Dash or using Terminal.

To run Savage from the Dash, open the Dash by clicking the Ubuntu logo icon in the launcher bar or by pressing the Super key on your keyboard. Search for "savage" and click the "Savage XR" icon.

Alternatively, to run Savage from the Terminal, you can navigate to the folder containing "savage.bin" (if you aren't already in that folder in Terminal) and execute it like this:
drfunko@ubuntu:~$ cd savage-xr
drfunko@ubuntu:~/savage-xr$ ./savage.bin

The game will begin by running its auto-updater to download and install updates, then afterwards it will enter the game.

If you find that Savage still won't start at this point, go back through this guide again, starting from step 3. It's possible that you may have missed a required file in step 3, or made an error in step 4 or 5, resulting in some or all of the packages not being installed correctly.

7. Resolve graphical issues with video card drivers

When playing Savage, you will either have no graphical issues or you may discover graphical problems such as missing textures on the 3D models. If you experience graphical problems while playing the game, the default drivers in Ubuntu may not be adequate and you'll likely need to install the proper drivers for your graphics hardware.

There are many different types of video cards or other graphics hardware. To find the right driver software for your particular system, you'll need to know what hardware your computer has. If you don't know what graphics hardware you have, try looking on your computer manufacturer's website or look for labels on the exterior of your computer. If you still can't find any info, run this command in Terminal, which will output info about your graphics hardware:
drfunko@ubuntu:~$ lspci -knn | grep -A2 VGA

If you happen to have an Intel CPU with integrated graphics (as my laptop does), then Intel provides downloadable files on their website that you can use. Go to Intel's Download Center, use the "Find by Category" search tool to select "Graphics Drivers" and then your CPU model. You'll likely be directed towards Intel's Open Source site to download the latest "Intel Graphics Installer for Linux" tool. Once you've installed that program, run it to install the proper driver for your system.

If you have a different brand of graphics hardware, you'll have to do some searching on your own to find the proper drivers. Here are some suggestions to point you in the right direction:

AMD / ATI graphics hardware (such as Radeon cards):

Nvidia graphics hardware (such as GeForce cards):


Thanks for reading through this guide. Hopefully, it can help you enjoy Savage XR on your 64-bit Ubuntu 14.04 system.


Gratitude to the Free/Libre Software movement, where GNU/Linux allows you to fix any software problem by modifying the system yourself, as seen in this guide. With a similar problem on a closed platform like Windows or Mac OS, fixing it would be impossible.

Thanks to HugiN for Savage installation advice and pointing me in the right direction.

Have fun,

DrFunko, aka. DogTheBountyHunter
« Last Edit: May 14, 2015, 01:21:02 am by DogTheBountyHunter » Logged
Posts: 9

View Profile
« Reply #1 on: November 27, 2014, 12:47:34 am »

[This is a reserved post, just in case I need to expand the guide at a later date. Initial post is already at the 20,000 character limit.]
XR Main Developer
Legendary Member
Posts: 4606

beware, for this is the everbroken...

View Profile
« Reply #2 on: November 27, 2014, 03:54:43 pm »


Melee enthusiast
Newerth Shoutcaster
Hero Member
Posts: 687

Duels Duels Duels

View Profile WWW
« Reply #3 on: November 28, 2014, 07:39:36 am »

HUGE thanks Smiley

Newerth Council
Full Member
Posts: 157

And who are YOU?

View Profile WWW
« Reply #4 on: December 01, 2014, 07:48:29 pm »

@drfunko: you got it! good to see that guide - nice work Smiley

"Nothing is impossible, the word itself says: 'I'm possible'!"
Audrey Hepburn

Posts: 2

View Profile
« Reply #5 on: January 02, 2016, 07:22:40 pm »

everything's installed and i got the game to open and run.. but i'm not getting any audio D:
XR Mapper
Full Member
Posts: 243

I love to create maps

View Profile
« Reply #6 on: January 02, 2016, 07:24:39 pm »

i had the same problem today , and I fixed it , open savage go to Options/system/sound find driver and try with all drivers you have there until it will work , restart savage after any change ..

ed: first driver is for audio , second is for microphone ..
« Last Edit: January 02, 2016, 07:27:12 pm by kLLik » Logged

just ask..
Posts: 2

View Profile
« Reply #7 on: January 02, 2016, 07:38:27 pm »

i figured out my problem. I wasn't using my speakers at the time cuz my headphones were plugged into my microphone's output (it's a special mic) so i had my speakers off. it's been playing sound to my speakers instead of what ubuntu's set to send sound through. not sure how to force the client to route audio through system's set audio output


i think the game is glitched cuz i'm doing the human tutorial (first timer here) and i get to the point where it tells me to make the arsenal by pressing R. I walked up to the green waypoint and it disappears and there's nothing for me to do. I can't build it. I looked at a person's video and it looks like there's supposed to be an outline of a structure (the arsenal I assume) for me to build.. i don't see that in my client at all.

at this timstamp 4:45 that structure isn't on my screen at that point in the tutorial

I've been through it about 5 or 6 times and i've tried it with and without obtaining 500+ of the red stone stuff cuz it completely skips that part for me and says there's enough supplies to build it already.

edit: fixed glitch by getting 500+ red stone before completing first waypoint given by announcer/commander
« Last Edit: January 02, 2016, 07:44:25 pm by LogSin » Logged
XR Main Developer
Legendary Member
Posts: 4606

beware, for this is the everbroken...

View Profile
« Reply #8 on: January 02, 2016, 09:10:31 pm »

Thanks for the report, LogSin. The issue is known to affect a very small amount of players and with our limited resources it was kind of hard to reproduce. However, given your workaround, we might be able to produce a fix for the human tutorial that doesn't imply major restructuring - including new voice recordings.

Thanks again.

Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.044 seconds with 19 queries.