Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2017, 01:01:31 pm

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The XR1.1 Client is out now! Download it now!
188605 Posts in 10883 Topics by 17932 Members
Latest Member: MrStoner
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  INFO: Solving Linux issue with "white screen at startup"
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: INFO: Solving Linux issue with "white screen at startup"  (Read 15823 times)
Sorrat
Newbie
*
Posts: 6


View Profile
« on: February 02, 2011, 09:14:51 pm »

There was a problem, have seen here a few times: white screen when starting the game.
Searched in forum, found the reason: lack of support for DRI drivers and S3 Texture Compression (S3TC).
I havn't problems with DRI, but support S3TC was not.
 
check S3TC:
Code:
glxinfo | grep -i s3
should be:
Code:
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_compression_s3tc, GL_S3_s3tc

check DRI:
Code:
glxinfo | grep rendering
should be:
Code:
direct rendering: Yes

Describe how to solve the problem with S3TC.
-To enable S3TC drivers Mesa DRI, need to install the library libtxc_dxtn (for example, from http://debian-multimedia.org/dists/unstable/main/binary-i386/package/libtxc-dxtn0.php)
-Install the dependencies required to compile the library from source:
Code:
apt-get install gcc libgl1-mesa-dev
-Check the results
Code:
glxinfo | grep -i s3

After this game was to run properly.
« Last Edit: September 07, 2013, 10:11:17 pm by Groentjuh » Logged
Thorm
Newbie
*
Posts: 2


View Profile
« Reply #1 on: May 02, 2011, 05:33:55 pm »

Hi,
thanks a lot for the tip Afro. I also had the white screen problem with the Intel i965-va-driver. For Debian just add
Code:
deb http://www.debian-multimedia.org/ stable main
to your
Code:
/etc/apt/sources.list
and install
Code:
libtxc-dxtn0
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #2 on: May 30, 2011, 12:49:20 am »

This is really useful! I'll sticky it Smiley
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #3 on: July 22, 2011, 12:47:36 pm »

This might be an interesting alternative solution to this problem:

http://www.phoronix.com/scan.php?page=article&item=s2tc_s3tc_fix&num=1
Logged
mrinvader
Newbie
*
Posts: 1


View Profile
« Reply #4 on: August 25, 2011, 02:43:20 am »

Hi,
thanks a lot for the tip Afro. I also had the white screen problem with the Intel i965-va-driver. For Debian just add
Code:
deb http://www.debian-multimedia.org/ stable main
to your
Code:
/etc/apt/sources.list
and install
Code:
libtxc-dxtn0

This is also part of the xorg-edgers ppa.. I installed this on Ubuntu Natty 11.04 with an Intel GMA x4500 chipset. This also fixes " your graphics card is too old" error on regnum online!!

Thanks all!

This is why I love the open source community.

 -Tom Grin
Logged
Django
Administrator
Legendary Member
*****
Posts: 2557



View Profile
« Reply #5 on: January 04, 2012, 05:51:16 pm »

Another solution:

http://www.regnumonline.com.ar/forum/showthread.php?t=12422
Logged
Odys
Newbie
*
Posts: 9


View Profile
« Reply #6 on: April 01, 2012, 11:52:37 am »

Hello, I'm new to ubuntu so I don't know the syntax well. Are you sure your code is correct? When I paste glxinfo | grep-i s3 in terminal, it prints back: "grep-i: command not found". I tried putting a space between grep and -i like this: "grep -i". It doesn't print the "command not found" error, but yet it doesn't return anything. I know it must be some minor mistake but I am stuck Tongue
Logged
Odys
Newbie
*
Posts: 9


View Profile
« Reply #7 on: April 01, 2012, 11:55:20 am »

Tried to solve the problem with the regnum solution, yet in the driconfig there was no s3 reference... I'm going to install the library you mention but I still don't have a clue of whether s3 is okay in my pc except from the problem I have with running the game... Well, I suppose it is enough ^^
« Last Edit: April 01, 2012, 12:09:47 pm by Odys » Logged
Odys
Newbie
*
Posts: 9


View Profile
« Reply #8 on: April 01, 2012, 12:44:08 pm »

-Install the dependencies required to compile the library from source:
Code:
apt-get install gcc libgl1-mesa-dev
-Check the results
Code:
glxinfo | grep-i s3

After this game was to run properly.


What do you mean in the first line? How can I compile the library, which is in the downloads folder, from source?
Logged
Odys
Newbie
*
Posts: 9


View Profile
« Reply #9 on: April 02, 2012, 09:03:05 pm »

Anyone give a hint about the above instruction?
Logged
biggeruniverse
Disrespectful Newerth Coder and Occasional Admin
Hero Member
*****
Posts: 929


Savage Days


View Profile
« Reply #10 on: April 03, 2012, 02:42:25 am »

apt-get -b
Logged


https://twitter.com/SavageRebirth
Quote from: Helios
You mean an already 7 yr old game is going to die eventually?  Good call there Nostradumbass
Odys
Newbie
*
Posts: 9


View Profile
« Reply #11 on: April 03, 2012, 04:28:24 pm »

Ok, I got a clue. I have to use sudo apt-get install after having used "cd Downloads" to turn to the folder in which the downloaded archive is. What now? When I  paste the archive's name and press enter it says"E: Unable to locate package libtxc-dxtn0_1.0.1-0.3_i386.deb
E: Couldn't find any package by regex 'libtxc-dxtn0_1.0.1-0.3_i386.deb'"

Common, I'm just so close, show patience ^^
Logged
happy
Oschore Breeder
Sr. Member
****
Posts: 325



View Profile
« Reply #12 on: April 03, 2012, 08:42:22 pm »

Please copy-paste the exact commands you use. Like this:

Code:
cd Downloads
dir
Logged
Odys
Newbie
*
Posts: 9


View Profile
« Reply #13 on: April 03, 2012, 09:03:24 pm »

ok then, here it is:
Code:
odysseas@Odysubuntu:~$ cd Downloads
odysseas@Odysubuntu:~/Downloads$ sudo apt-get install libtxc-dxtn0_1.0.1-0.3_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libtxc-dxtn0_1.0.1-0.3_i386.deb
E: Couldn't find any package by regex 'libtxc-dxtn0_1.0.1-0.3_i386.deb'
odysseas@Odysubuntu:~/Downloads$
Logged
happy
Oschore Breeder
Sr. Member
****
Posts: 325



View Profile
« Reply #14 on: April 04, 2012, 01:36:09 pm »

Try
Code:
sudo dpkg --install Downloads/libtxc-dxtn0_1.0.1-0.3_i386.deb
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.043 seconds with 19 queries.