Newerth Forums

Archive => Server Forum => Topic started by: Silent Killer on October 12, 2014, 08:00:43 am



Title: xr 1.1 server issue
Post by: Silent Killer on October 12, 2014, 08:00:43 am
OS: Win8 Pro
LOG:
************************************************************
Silverback Engine starting up...
[2014-10-06]
[15:02:51]
VERSION INFO
=====================================
(video res goes here)
Silverback build date: Oct  5 2014
Net Protocol: 12
Silverback XR

Version stamp is now OFF
running with glib version 2.2.3

----------------------Load Archives----------------------
savage0.s2z archive loaded!
savage1.s2z archive loaded!
---------------------Archives Loaded---------------------
Initializing World Engine...
Initializing Physics Engine...
Port 57206 opened
Initializing Game...
 * Initializing States...
 * Initializing Team Upgrades...
 * Initializing Objects...
Python Paths: C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage9.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage8.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage7.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage6.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage5.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage4.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage3.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage2.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage1.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/savage0.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/lib;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/lib/3rd-party.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/lib/MySQLdb.zip;C:/Users/Maxim-hejam/Desktop/XR1.1 N4B/game/python/lib/python272.zip
Python Error: Cannot retrieve function chatmessage!
<type 'exceptions.AttributeError'>
'module' object has no attribute 'chatmessage'
Python Error: Cannot retrieve function privatemessage!
<type 'exceptions.AttributeError'>
'module' object has no attribute 'privatemessage'
Python Error: Cannot retrieve function clientconnect!
<type 'exceptions.AttributeError'>
'module' object has no attribute 'clientconnect'
Python Error: Cannot retrieve function clientdisconnect!
<type 'exceptions.AttributeError'>
'module' object has no attribute 'clientdisconnect'
Python: Initializing Server-Side...
 * Initializing Maps...
 * Initializing Triggers...
Checking "xr_n4b_omega3" against repository (svr_mapurl)...
"xr_n4b_omega3" is already up-to-date.
Loaded world "xr_n4b_omega3"
Server started
Cmd_Register Error: Command triggerlist already exists
Python: Initializing Bots...
Resetting World Physics...
Reloading Server Config...
Loading Game from standard/XR.objlist:
 * Loading States...
 * Loading Meta Config...
 * Loading Objects...
 * Generated techtree with 117 obj entries and 0 tu entries
 * Loading Game Scripts...
Python: Server Empty...
(27 3)
Port 11235 opened
Listening for TCP/IP connections on port 11235
masterserver.savage.s2games.com resolved to 162.243.214.228
Couldn't connect to tcp port 11236 on 0 to request a firewall test
Allocated 28180480 bytes for client data
Max clients set to 40
Sent heartbeat
(8 0) The time of day was modified
Sent heartbeat
*************************************************
I think this is the problem: Couldn't connect to tcp port 11236 on 0 to request a firewall test
any ideas?

cheers, SK


Title: Re: xr 1.1 server issue
Post by: Hakugei on October 12, 2014, 02:51:32 pm
Update your server.
And if it is, check your extracted sv_events.py; it's missing the new events - adjust it with the new ones inside the archive.
That'll take care of your python errors.
May or may not fix your other problem.


Title: Re: xr 1.1 server issue
Post by: Silent Killer on October 13, 2014, 02:25:47 pm
Update your server.
And if it is, check your extracted sv_events.py; it's missing the new events - adjust it with the new ones inside the archive.
That'll take care of your python errors.
May or may not fix your other problem.
I have Crashday's notification system on board. It contains outdated sv_events...
I will disable this. Maybe it will helps.


Title: Re: xr 1.1 server issue
Post by: Hakugei on October 13, 2014, 02:27:39 pm
You don't need to disable them.
Just add the 4 new events to it as well.


Title: Re: xr 1.1 server issue
Post by: Silent Killer on October 13, 2014, 02:46:39 pm
You don't need to disable them.
Just add the 4 new events to it as well.
Thanks Hakugei! It solve python problems but cause of the firewall bug  my server isn't broadcasting to masterserver... Terrible...


Title: Re: xr 1.1 server issue
Post by: Hakugei on October 13, 2014, 02:53:31 pm
The question then is why your connection can't connect.


Title: Re: xr 1.1 server issue
Post by: Silent Killer on October 13, 2014, 02:56:30 pm
The question then is why your connection can't connect.
XR 1.0 server is working fine...


Title: Re: xr 1.1 server issue
Post by: Silent Killer on October 13, 2014, 02:58:49 pm
I had stringtables issue. But after 2 month of magic lame-coding I solve it... So need to lame-code more :3


Title: Re: xr 1.1 server issue
Post by: Hakugei on October 13, 2014, 03:02:28 pm
XR 1.0 server is working fine...
1.1 doesn't change any of that.
So maybe one of your files got overwritten through the update.


Title: Re: xr 1.1 server issue
Post by: Silent Killer on October 13, 2014, 03:05:58 pm
XR 1.0 server is working fine...
1.1 doesn't change any of that.
So maybe one of your files got overwritten through the update.
Any ideas which file?