Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2014, 02:31:29 am

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The RC3 Client is out now! Download it now!
179358 Posts in 10205 Topics by 16787 Members
Latest Member: Bboy_Izilla
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  Support Forum
| | |-+  [SOLVED] Impossible to start on Ubuntu 12.04 x64
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [SOLVED] Impossible to start on Ubuntu 12.04 x64  (Read 3100 times)
Pierr0x
Newbie
*
Posts: 4


View Profile
« on: October 19, 2012, 01:40:59 am »

Hello !!

I installed the lastest version of Ubuntu 12.04 x64, installed my graphics drivers and downloaded the savage xr 1.0 client installer, installation works but the game is not starting.
When I try to start savage.sh or savage.bin in a terminal it gaves me this :
Code:
./savage.bin: error while loading shared libraries: libXft.so.2: cannot open shared object file: No such file or directory
And with silverback.bin it gives me this :
Code:
./silverback.bin: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
Before that it gave me an error with LD lib problem, I solved it by redefining the environment variable of LD library with export "LD_LIBRARY_PATH"

I think savage can't find my libs installed on my system because all the files asked by the game are in my computer in the folder /usr/lib/x86_64-linux-gnu/ or /lib/x86_64-linux-gnu/

Do you know how I could make savage work ?

I searched on the forum and on google without finding the solution, sorry.

I thank you in advance.
« Last Edit: October 19, 2012, 03:59:21 pm by Pierr0x » Logged
Pierr0x
Newbie
*
Posts: 4


View Profile
« Reply #1 on: October 19, 2012, 02:10:37 am »

Sorry for the double post, I solved the issue with this command :

Code:
sudo apt-get install ia32-libs

It installed all the libs in 32 bit x86 version and now everything works fine after running savage.sh

Hope my post will be usefull for someone Smiley
Logged
Faun
carn =/= hax
XR Developer
Hero Member
*****
Posts: 924


Hear a flute in the forest...


View Profile
« Reply #2 on: October 19, 2012, 02:30:20 am »

impressive afro
Logged

Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.026 seconds with 19 queries.