Welcome, Guest. Please login or register.
Did you miss your activation email?
August 23, 2014, 02:23:37 pm

Login with username, password and session length
Search:     Advanced search
Savage: XR is a new patch for Savage, created by the Newerth.com staff. The RC3 Client is out now! Download it now!
177965 Posts in 10135 Topics by 16663 Members
Latest Member: Vanity59
* Home Forum Wiki Help Search Login Register
+  Newerth Forums
|-+  Savage XR
| |-+  General Savage XR Discussion
| | |-+  INFO: XR 1.0 Installers Need Testing!
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 3 Go Down Print
Author Topic: INFO: XR 1.0 Installers Need Testing!  (Read 7869 times)
Django
Administrator
Legendary Member
*****
Posts: 2548


Do I have bad redeye?


View Profile
« on: August 07, 2012, 06:49:12 pm »

We're very close to releasing XR 1.0 to the public but before we do we need to test the new installers. Here they are:

Clients:

Stable "Production" channel:

xr_setup-1.0-cl_win_prod.exe
xr_setup-1.0-cl_lin_prod.bin
xr_setup-1.0-cl_osx_prod.dmg

Unstable "Testing" channel:

xr_setup-1.0-cl_win_testing.exe
xr_setup-1.0-cl_lin_testing.bin
xr_setup-1.0-cl_osx_testing.dmg

Oldstable "Final" channel:

xr_setup-1.0rc3-final-cl_win.exe
xr_setup-1.0rc3-final-cl_lin.bin
xr_setup-1.0rc3-final-cl_osx.dmg

Servers:

Stable "Production" channel:

xr_setup-1.0-sv_win_prod.7z
xr_setup-1.0-sv_lin_prod.7z

Unstable "Testing" channel:

xr_setup-1.0-sv_win_testing.7z
xr_setup-1.0-sv_lin_testing.7z

The production installers will not work until we migrate all the RC3 installers already being used to 1.0 (by merging the current testing a-u file base to the production a-u) and the mac 1.0 versions will be available soon.

Please help test them and report any bugs! Even if you don't have any issues please let us know here.
« Last Edit: September 24, 2012, 03:28:49 pm by Django » Logged
DarkStar
Evolved Darkness
Newerth Referees (US)
Super Hero Member
*****
Posts: 1101


Dont drink and drive...smoke and fly...


View Profile WWW
« Reply #1 on: August 07, 2012, 08:38:07 pm »

Installing now. Thank you Dj, heard you put a lot of work into these over the past couple of days...thanks again. Thanks to the other devs as well.
Logged

Daemon
Administrator
Legendary Member
*****
Posts: 3712


beware, for this is the everbroken...


View Profile
« Reply #2 on: August 08, 2012, 06:54:00 pm »

Please note that the installers we primarily need to be tested are the following:

Clients:
xr_setup-1.0-cl_win_testing.exe
xr_setup-1.0-cl_lin_testing.bin

Servers:
xr_setup-1.0-sv_win_testing.7z
xr_setup-1.0-sv_lin_testing.7z

RC3 support will be discontinued after XR 1.0 release. Until then it is kept as stable release.
Logged


My black list: Mein (hax0r, troll), Slayer (multiclanner), biggeruniverse (XR thief, troll), Robbo (thug and liar), Thrill (junkie)
shuN
Perverted yet determined
Map Admins
Sr. Member
*
Posts: 414



View Profile
« Reply #3 on: August 08, 2012, 09:14:58 pm »

will current test clients be automatically updated to the 1.0 release?
Logged

Darkness shines in even the brightest of light.

Quote from: Standard
when i tried www(comma)google.com something didnt work...
Quote from: Cross
add my face to the crotch of savage
Daemon
Administrator
Legendary Member
*****
Posts: 3712


beware, for this is the everbroken...


View Profile
« Reply #4 on: August 08, 2012, 09:24:08 pm »

There is no difference between 1.0 testing and 1.0 prod. There will be one after we release, because as in RC3's case, 1.0 PRODUCTION will be kept as is until major patches or fixes, which will be made and tested on TESTING.

These installers are not PROD, they're TESTING. Which means you just need to install them, test them, and report possible bugs so we can fix them and turn them into PROD.
Logged


My black list: Mein (hax0r, troll), Slayer (multiclanner), biggeruniverse (XR thief, troll), Robbo (thug and liar), Thrill (junkie)
shuN
Perverted yet determined
Map Admins
Sr. Member
*
Posts: 414



View Profile
« Reply #5 on: August 08, 2012, 09:30:12 pm »

ok.. so I've already begun testing then.  Understood.  wink
Logged

Darkness shines in even the brightest of light.

Quote from: Standard
when i tried www(comma)google.com something didnt work...
Quote from: Cross
add my face to the crotch of savage
carnivor
Newbie
*
Posts: 5


View Profile
« Reply #6 on: August 08, 2012, 09:47:41 pm »

Hello Deamon,

my problem still exists also with the new installer. I can install it but the game wont start. If i run the game from the console (savage.bin) then following message appears:

*****@localhost xr1 test neu]$ ./savage.sh
./savage.bin: ./libs/libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/libxml2.so.2)


My solution for this problem is (the order is relevant!):

1. I delete the file 'libz.so.1' from the game 'libs' folder
2.run 'savage.bin from the console (The updater appears, the 'savage0.szg' file gets created and so on...)
3.(the game already doesnt start at this point if i run it from the console! The same error message as above!)
4. delete the file 'libz.so.1' from the game 'libs' folder again
5. copy the file 'libz.so.1' and 'libz.so.1.2.6' from my distribution 'lib' folder to the game 'libs' folder

Then i have to create manually a new desktop shortcut to the 'savage.bin' file to run the game. (The old shortcut doesnt work. If i run 'savage.sh' from the console the game starts. I dont know why!)

Some Informations about my system:

Linux distribution: Mageia2 (really new and up to date)


This problem doesnt appear on my old distribution 'Mandriva 2009.1'


So i guess, my distribution needs a new version of this file, other than the version that is delivered with the game.



I hope you can understand what i have written, because my english is not so good. If you need any additional information about my system and packet-versions dont  hesitate to contact me.


But in general i would say: XR1 is great, runs fine and all devs have done a really good job!!!!!!!!!!!!!!!!!!

 afro  afro  afro  afro
Logged
Crashday
XR Developer
Full Member
*****
Posts: 179


Chiprels rock!


View Profile
« Reply #7 on: August 08, 2012, 10:18:15 pm »

try installing this:

ia32-libs
lib32nss-mdns

fixed my errors
Logged

carnivor
Newbie
*
Posts: 5


View Profile
« Reply #8 on: August 08, 2012, 10:43:03 pm »

@Crashday
I dont think this packages are relevant for this problem!

1. This packages arent available for my distribution
2. Package ia32-libs is for 64bit debian system to give them 32bit possibilitys --> i have a 32bit system (not debian based)
3. Package lib32nss-mdns has something to do with DNS and host name resolution --> also not relevant

The lib libz.so.1 is needed to create the files 'savage0.s2z' and 'newerth.s2z'. Its a compressing tool. Because if you install savage completely new, the files 'savage0.s2z'  and 'newerth.s2z'  doesnt exist. They will be created after the first game startup with this packing lib.

Sorry.
« Last Edit: August 08, 2012, 11:20:10 pm by carnivor » Logged
SavageBeard
Full Member
***
Posts: 158


View Profile
« Reply #9 on: August 08, 2012, 10:50:57 pm »

Hey,

I am crashing as soon as I click "Login". Game just freezes and the audio gets on repeat. Don't have any crash logs or anything, though, didn't find any. Any fix?
Logged
Daemon
Administrator
Legendary Member
*****
Posts: 3712


beware, for this is the everbroken...


View Profile
« Reply #10 on: August 08, 2012, 10:58:47 pm »

Which installed did you use?

Anyway, say you used the win-testing installer, go to www.savageXR.com and download the old win installer from them. Install it, let it update completely, and see if that works better. Thanks!
Logged


My black list: Mein (hax0r, troll), Slayer (multiclanner), biggeruniverse (XR thief, troll), Robbo (thug and liar), Thrill (junkie)
SavageBeard
Full Member
***
Posts: 158


View Profile
« Reply #11 on: August 08, 2012, 11:38:47 pm »

Which installed did you use?

Anyway, say you used the win-testing installer, go to www.savageXR.com and download the old win installer from them. Install it, let it update completely, and see if that works better. Thanks!

I used the windows installer ont he first post of this site. Also tried the new one that you just linked, and it's the same problem.
Logged
Daemon
Administrator
Legendary Member
*****
Posts: 3712


beware, for this is the everbroken...


View Profile
« Reply #12 on: August 10, 2012, 09:50:13 am »

Which installed did you use?

Anyway, say you used the win-testing installer, go to www.savageXR.com and download the old win installer from them. Install it, let it update completely, and see if that works better. Thanks!

I used the windows installer ont he first post of this site. Also tried the new one that you just linked, and it's the same problem.

You should probably install new version of your video card and sound card drivers, to begin with.
Logged


My black list: Mein (hax0r, troll), Slayer (multiclanner), biggeruniverse (XR thief, troll), Robbo (thug and liar), Thrill (junkie)
Zackorrigan
Newerth Donator
Sr. Member
*****
Posts: 304


View Profile
« Reply #13 on: August 12, 2012, 08:34:06 pm »

i'm testing the mac osx one and i i get one  problem, i tryed to join the evolution server, but "the server is using an object that we don't have "human_mech".

exept that i didn't notice others problems for the moment
Logged
Daemon
Administrator
Legendary Member
*****
Posts: 3712


beware, for this is the everbroken...


View Profile
« Reply #14 on: August 12, 2012, 09:36:49 pm »

That is the 'final' RC3 installer. The MacOSX 1.0 installer is not made yet. If you want to use 1.0 on Mac, you need to install RC3, edit your au.cfg and replace isTesting 0 with isTesting 1, and let it update.
Logged


My black list: Mein (hax0r, troll), Slayer (multiclanner), biggeruniverse (XR thief, troll), Robbo (thug and liar), Thrill (junkie)
Pages: [1] 2 3 Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2007, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.057 seconds with 19 queries.