Main Menu
Savage XR
XR Development
Active Servers
You must enable javascript to see
this content!
Map of the Moment
XR Official Website
SavageXR.com
Teamspeak 3
You must enable javascript to see this content!
Bug Tracker
Viewing Bug #226: No soundcard driver available to choose but sound works
Category Savage Client Posted By Apparently unskilled. Last Updated Feb 17, 2009
Assigned to Extreme Status Unconfirmed Priority Normal
Affected Products XR Windows
Description Trying to change the system options in main menu, I was unable to choose my soundcard driver (Realtek HD Audio output). If I click the dropdown menu, no driver appears (no primary, secondary etc.)

While playing, sound is enabled but it sounds worse than in SFE.
Attachment
*  no+soundcard.jpg



Pages: [1] [2]
Comments
Extreme
Modmaster General
Newbie

on 2008-12-29 06:18:31

Automated Messages:
The assignee of this bug has been changed to Extreme.

Admin Comment:
Mine
Extreme
Modmaster General
Newbie

on 2008-12-29 06:18:51

LuLu, are you still having this problem?
Apparently unskilled.
Newbie

on 2008-12-30 15:00:52

I updated XR nearly every second time before starting it and nothing changed. Now I see the options for mix-rate and output channels but I still can't choose any driver. When having a look at the debug.log, it shows:

Using sound output driver: Direct Sound
Using driver 0
---------------------------------------------------------
Driver capabilities
---------------------------------------------------------
- Driver supports hardware 3D sound!
- Driver supports EAX 2 reverb!

But when looking at the options in the menu, there is nothing to choose, when clicking the field for dropdown menu, it shows a black field, nothing else.

Should I try to uninstall and reinstall the driver or Savage?
 

*  no_soundcard_b.jpg
Extreme
Modmaster General
Newbie

on 2009-01-02 04:56:04

Please delete your startup.cfg file and try again.  If this doesn't fix it try reinstalling XR.  If you are still having problems then check your sound drivers.

If none of those work please do start -> run -> msinfo32, file -> save, zip the NFO file and attach it.
Apparently unskilled.
Newbie

on 2009-01-04 22:45:59

Uninstalled XR, installed it again. Started XR, still had this problem. Afterwards, tried to uninstall the soundcard driver (it was a "try", because it didn't work as I thought it would supposed to be -> uninstalling via program-list in XP was impossible because nothing happend after clicking uninstall). So I took the driver setup and installed it (while having the old one installed, same version).

The attached zip-file has two .nfo files, one before un-/reinstalling the driver, one after doing so.
 
*  sysNFO.zip
Extreme
Modmaster General
Newbie

on 2009-01-05 17:02:31

Please try changing your locale to US English and let me know if this makes any difference.
Apparently unskilled.
Newbie

on 2009-01-06 11:04:30

I changed the locale for the driver to English, afterwards I was able to completely uninstall the driver. I did, restarted the computer, installed the driver again, started XR, still the same problem.
Darkbread told me which locale you mean > I changed it - no difference.

coruna
Newbie

on 2009-02-13 11:30:59

I got same problem. I have also an Realtek HD audio chipset on my mainboard and tried already stuff recommended but nothing helped. I attached my dxdiag log for detailed system specs. My sound in savage xr is kinda awfully loud - Its like a 'loudness' function is now on and there is like to much bass even if i turn my subwoofer almost off really strange behaviour. But well i didnt changed anything at my sound configuration.
 
*  DxDiag.zip
Extreme
Modmaster General
Newbie

on 2009-02-13 22:23:47

LuLu, could you be more specific about "sounds worse"?

It appears both of you are using the Realtek HD Audio driver under a German locale.  I am going to compile a test build of XR later for you to get me some debug information from to see if I can pin down a source, or if I start blaming the drivers Smiley

Damus
Newbie

on 2009-02-16 15:38:53

I have the same problem but I have C-Media Wave Device...
Pages: [1] [2]
 
Post Comment
You need to login to post a comment
Personal Menu
Welcome, Guest. Please login below or register
 
 
111 Guests
0 Users
Please welcome nigdarogp, our newest member.
Become a Fan
Give us +1
Random Poll
What do you like most in any newly made maps?
Instant action!
Great looking scenery.
Balanced gameplay, long matches.
Niche gameplay, scripts!
Latest Image
Latest Image
Click to view
Shout Out Loud
Posted by Fenrir
😅
Posted by Mr_Matt
good maps*
Posted by Mefix
Are you saying I need to make NEW MAPS?!
Posted by Mr_Matt
i dont like the new maps :(
Posted by EpicIkaros
Made something to keep in some what contact with people, so we could start games earlier. If intrested in that,come join our discord!Discord is omething where people communicate in! Like teamspeak, but has a lot more features! Visit us here: https://tinyurl.com/xrdiscord
Log in to shout!